[ Lumen 5.3 文档 ] 起步 —— 配置

Lumen

1、简介 Lumen框架的所有配置项都放在配置文件.env  中。 2、访问配置值 你可以使用全局的辅助函数config来访问配置值,配置值可以通过“.”来分隔配置文件和配置项,如果配置项不存在的话则会返回默认值: $value = config(‘app.locale’); 如果要在运行时设置配置值,传递一个数组到config函数: config([‘app.locale’ =>…

[ Laravel 5.3 文档 ] 附录 —— 包开发

laravel文档

1、简介 包是添加功能到 Laravel 的主要方式。包可以提供任何功能,小到处理日期如 Carbon,大到整个 BDD 测试框架如 Behat。 当然,有很多不同类型的包。有些包是独立的,意味着可以在任何框架中使用,而不仅是 Laravel。比如 Carbon 和 Behat 都是独立的包。所有这些包都可以通过在composer.json文件中请求以便被 Laravel 使用。 另一方…

[ Laravel 5.3 文档 ] Eloquent ORM —— 起步

laravel文档

1、简介 Laravel 自带的 Eloquent ORM 提供了一个美观、简单的与数据库打交道的 ActiveRecord 实现,每张数据表都对应一个与该表进行交互的“模型”,模型允许你在表中进行数据查询,以及插入、更新、删除等操作。 在开始之前,确保在config/database.php文件中配置好了数据库连接。更多关于数据库配置的信息,请查看文档。 2、定义模型 作为开始,让我们…

[ Laravel 5.3 文档 ] 数据库 —— Redis

laravel文档

1、简介 Redis是一个开源的、高级的键值对存储系统,经常被用作数据结构服务器,因为其支持字符串、Hash、列表、集合和有序集合等数据结构。在Laravel中使用Redis之前,需要通过Composer安装predis/predis包: composer require predis/predis 配置 应用的Redis配置位于配置文件config/database.php。在这个文件…

[ Laravel 5.3 文档 ] 数据库 —— 起步

laravel文档

1、简介 Laravel 让连接多种数据库以及对数据库进行查询变得非常简单,不论使用原生 SQL、还是查询构建器,还是 Eloquent ORM。目前,Laravel 支持四种类型的数据库系统: MySQL Postgres SQLite SQL Server 配置 Laravel 让连接数据库和运行查询都变得非常简单。应用的数据库配置位于config/database.php。在该文件…

[ Laravel 5.3 文档 ] 起步 —— 配置

laravel文档

1、简介 Laravel 的所有配置文件都存放在 config 目录下,每个配置项都有注释,以保证浏览任意配置文件的配置项都能直观了解该配置项的作用及用法。 2、访问配置值 你可以使用全局辅助函数 config 在应用的任意位置访问配置值,该配置值可以文件名+“.”+配置项的方式进行访问,当配置项没有被配置的时候返回默认值: $value = config(‘app.timezone’)…

《程序员修炼之道:从小工到专家》第五章:弯曲或折断(1)

程序员修炼之道:从小工到专家

在“可撤销性”中,我们谈到不可撤销的决策的危险,在本章,我们将告诉你怎样做出可撤销的决策,以使你的代码在面对你不确定的世界时保持灵活性和可适应性。 一、解耦与得墨忒耳法则 好篱笆促成好邻居。 在“正交性”和“按合约设计”中,我们提出,编写“羞怯”的代码是有益的,但“羞怯”的工作方式有两种:不向别人暴露自己,不太与太多人打交道。 把你的代码组织成最小组织单位(模块),并限制它们之间的交互,…

Laravel & Lumen RESTFul API 扩展包:Dingo API(一) —— 安装配置篇

Dingo API

Dingo API 为开发者提供了一整套工具以便帮助你轻松、快捷的构建自己的API。这些工具包括: 内容协商 多认证适配器 API版本 频率限制 响应转化和格式化 错误及异常处理 内部请求 API文档 1、安装 安装该扩展包之前需要保证已经安装以下程序: Laravel 5.1+ 或 Lumen 5.1+ PHP 5.5.9+ 然后通过如下Composer命令安装扩展包: compose…

使用 Entrust 扩展包在 Laravel 5 中实现 RBAC 权限管理(一):安装配置篇

Laravel中安装配置Entrust

Entrust为我们在Laravel中实现基于角色的权限管理(RBAC)提供了简洁灵活的方式。 1、安装 想要在Laravel中使用Entrust,首先需要通过Composer来安装其依赖包: composer require zizaco/entrust 5.2.x-dev 安装完成后需要在config/app.php中注册服务提供者到providers数组: Zizaco\Entru…

使用 Laravel Generator 快速为 Laravel 应用生成CRUD、API、测试用例代码 —— 安装篇

使用Composer安装Laravel Generator

在开始使用Laravel Generator之前我们先来安装它,首先需要添加这些包到composer.json文件的require-dev: “infyomlabs/laravel-generator”: “dev-master”, “infyomlabs/core-templates”: “dev-master”, “laravelcollective/html”: “5.2.*” 注…